Kautsanux Blog

I would like to apologise for hacking Levon Haykazyan’s facebook account and for harassing his friends. I was being an absolute asshole and I hope you will forgive me this.

Hacker Sidom

Conky

Posted on: June 29, 2010

Conky, Program Monitoring System di Desktop
#Tentang Conky
Conky adalah suatu program sederhana dan ringan yang dapat berjalan di system
GNU/Linux dan BSD dan berlisensi General Public License (GPL). Conky dapat di costumize
fungsinya untuk menampilkan informasi system di desktop, misalnya; versi kernel, space
hardisk, memory usage, temperatur CPU dan lainnya serta dapat dimodifikasi tampilannya
sesuai selera.

#Instalasi Conky
Conky dapat berjalan di GNU/Linux dan BSD dan pada kesempatan ini akan dibahas
bagaimana instalasi Conky di GNU/Linux terutama pada distro Ubuntu. Untuk menginstall
Conky cukup mudah karena sudah tersedia pada repository Ubuntu.
Buka terminal melalui Application – Accessories – Terminal, dan ketikkan perintah berikut
ini:
$ sudo apt-get install conky
Maka file-file yang diperlukan akan didownload dan conky akan terinstal otomatis. Setelah
instalasi conky selesai maka conky sudah dapat dijalankan melalui fasilitas run (Alt+F2)
ketik “conky” (tanpa tanda kutip). Kemudian lihat tampilan desktop anda sekarang, conky
sudah muncul tapi dengan tampilan yang sangat standar dan sangat sederhana, untuk itu
selanjutnya kita akan melakukan konfigurasi pada conky untuk membuatnya menjadi lebih
menarik.

#Konfigurasi Conky
Buatlah sebuah script conky pada direktori home anda (mis, /home/ubuntuku/).
Caranya:
$ gksu gedit /home/ubuntuku/.conkyrc
Setelah jendela teks editor terbuka, paste kode berikut ini kemudian save dan exit.
Read the rest of this entry »

Tags: ,

1. Langkah pertama adalah install Mikrotik RouterOS pada PC atau pasang DOM.

2. Login Pada Mikrotik Routers melalui console :
MikroTik v2.9.7
Login: admin
Password: (kosongkan)

Sampai
langkah ini kita sudah bisa masuk pada mesin Mikrotik. User default
adalah admin dan tanpa password, tinggal ketik admin kemudian tekan
tombol enter.

3. Untuk keamanan ganti password default
[admin@Mikrotik] > password
old password: *****
new password: *****
retype new password: *****
[admin@ Mikrotik]] >

4.Mengganti nama Mikrotik Router, pada langkah ini nama server akan
diganti misalkan“chaer-newbie” (silahkan ganti nama sesuka anda)
[admin@Mikrotik] > system identity set name=chaer-newbie
[admin@chaer-newbie] >

5. Melihat interface pada Mikrotik Router
[admin@chaer-newbie] > interface print
Flags: X – disabled, D – dynamic, R – running
# NAME TYPE RX-RATE TX-RATE MTU
0 R ether1 ether 0 0 1500
1 R ether2 ether 0 0 1500
[admin@chaer-newbie] >

6.
Memberikan IP address pada interface Mikrotik. Misalkan ether1 akan
kita gunakan untuk koneksi ke Internet dengan IP 192.168.0.1 dan ether2
akan kita gunakan untuk network local kita dengan IP 172.16.0.1

[admin@chaer-newbie] > ip address add address=192.168.0.1
netmask=255.255.255.0 interface=ether1
[admin@chaer-newbie] > ip address add address=172.16.0.1
netmask=255.255.255.0 interface=ether2

7. Melihat konfigurasi IP address yang sudah kita berikan
[admin@chaer-newbie] >ip address print
Flags: X – disabled, I – invalid, D – dynamic
# ADDRESS NETWORK BROADCAST INTERFACE
0 192.168.0.1/24 192.168.0.0 192.168.0.63 ether1
1 172.16.0.1/24 172.16.0.0 172.16.0.255 ether2
[admin@chaer-newbie] >

8. Memberikan default Gateway, diasumsikan gateway untuk koneksi internet adalah 192.168.0.254
[admin@Andre-Network] > /ip route add gateway=192.168.0.254

9. Melihat Tabel routing pada Mikrotik Routers
[admin@chaer-newbie] > ip route print
Flags: X – disabled, A – active, D – dynamic,
C – connect, S – static, r – rip, b – bgp, o – ospf
# DST-ADDRESS PREFSRC G GATEWAY DISTANCE INTERFACE
0 ADC 172.16.0.0/24 172.16.0.1 ether2
1 ADC 192.168.0.0/26 192.168.0.1 ether1
2 A S 0.0.0.0/0 r 192.168.0.254 ether1
[admin@chaer-newbie] >

10. Tes Ping ke Gateway untuk memastikan konfigurasi sudah benar
[admin@chaer-newbie] > ping 192.168.0.254
192.168.0.254 64 byte ping: ttl=64 time

11. Setup DNS pada Mikrotik Routers
[admin@chaer-newbie] > ip dns set primary-dns=192.168.0.10 allow-remoterequests=no
[admin@chaer-newbie] > ip dns set secondary-dns=192.168.0.11 allow-remoterequests=no

12. Melihat konfigurasi DNS
[admin@chaer-newbie] > ip dns print
primary-dns: 192.168.0.10
secondary-dns: 192.168.0.11
allow-remote-requests: no
cache-size: 2048KiB
cache-max-ttl: 1w
cache-used: 16KiB
[admin@chaer-newbie] >

13. Tes untuk akses domain, misalnya dengan ping nama domain
[admin@chaer-newbie] > ping yahoo.com
216.109.112.135 64 byte ping: ttl=48 time=250 ms
10 packets transmitted, 10 packets received, 0% packet loss
round-trip min/avg/max = 571/571.0/571 ms
[admin@chaer-newbie] >

Jika sudah berhasil reply berarti seting DNS sudah benar.

14.
Setup Masquerading, Jika Mikrotik akan kita pergunakan sebagai gateway
server maka agar client computer pada network dapat terkoneksi ke
internet perlu kita masquerading.
[admin@chaer-newbie]> ip firewall nat add action=masquerade outinterface= ether1 chain:srcnat
[admin@chaer-newbie] >

15. Melihat konfigurasi Masquerading
[admin@chaer-newbie]ip firewall nat print
Flags: X – disabled, I – invalid, D – dynamic
0 chain=srcnat out-interface=ether1 action=masquerade
[admin@chaer-newbie] >

Setelah
langkah ini bisa dilakukan pemeriksaan untuk koneksi dari jaringan
local. Dan jika berhasil berarti kita sudah berhasil melakukan
instalasi Mikrotik Router sebagai Gateway server. Setelah terkoneksi
dengan jaringan Mikrotik dapat dimanage menggunakan WinBox yang bisa di
download dari Mikrotik.com atau dari server mikrotik kita.

Misal Ip address server
mikrotik kita 192.168.0.1, via browser buka http://192.168.0.1 dan download WinBox dari situ.
Jika
kita menginginkan client mendapatkan IP address secara otomatis maka
perlu kita setup dhcp server pada Mikrotik. Berikut langkah-langkahnya :

1.Buat IP address pool
/ip pool add name=dhcp-pool ranges=172.16.0.10-172.16.0.20

2.
Tambahkan DHCP Network dan gatewaynya yang akan didistribusikan ke
client Pada contoh ini networknya adalah 172.16.0.0/24 dan gatewaynya
172.16.0.1
/ip dhcp-server network add address=172.16.0.0/24 gateway=172.16.0.1

3. Tambahkan DHCP Server ( pada contoh ini dhcp diterapkan pada interface ether2 )
/ip dhcp-server add interface=ether2 address-pool=dhcp-pool

4. Lihat status DHCP server
[admin@chaer-newbie]> ip dhcp-server print
Flags: X – disabled, I – invalid
# NAME INTERFACE RELAY ADDRESS-POOL LEASE-TIME ADD-ARP
0 X dhcp1 ether2
Tanda X menyatakan bahwa DHCP server belum enable maka perlu dienablekan terlebih dahulu pada langkah 5.

5. Jangan Lupa dibuat enable dulu dhcp servernya
/ip dhcp-server enable 0

kemudian cek kembali dhcp-server seperti langkah 4, jika tanda X sudah tidak ada berarti sudah aktif.

6. Tes Dari client
c:>ping http://www.yahoo.com

Untuk panduan bisa juga belajar di http://www.mikrotik.com

source :  Hacker Newbie

Tags:

Buku ini hadir dalam 3 seri yaitu, Bisa OOo Witer, Bisa OOo Calc dan Bisa OOo Math. Buku yang ditulis oleh Citra Paska atau lebih dikenal dengan Digirta sangat membantu bagi yang ingin mencari referensi tentang OpenOffice. Selain buku tentang OpenOffice Digirta juga menulis cerpen dan novel. Aktivitas didunia Free Open Source Software Digirta menjadi translator pada proyek Gnome.

Buku Bisa OpenOffice ini berlisensikan Creative Commons Attribution (CC-by). Walaupun saat ini OpenOffice sudah merilis versi 3.2, saya fikir buku Bisa OpenOffice ini masih relevan. Seperti yang tercantum dalam buku bahwa buku Bisa OpenOffice ini untuk kalangan pemula. Digirta sangat pandai dalam menyampaikan materi OpenOffice karena penulisannya menggunakan bahasa yang sederhana dan disertai gambar.
Tentunya siapapun sangat mudah membaca buku ini. Buku Bisa OOo Writer adalah buku tertebal dengan jumlah 166 halaman selanjutnya disusul Bisa OOo Calc 140 halaman dan terakhir Bisa OOo Math setebal 50 halaman. Saya fikir rugi jika tidak mempunyai buku Bisa OpenOffice ini. Silakan untuk mendapatkannya unduh di http://dirgitadevina.web.id :
Terimakasih buat Digirta yang telah bersedia untuk berbagi ilmu. Saya sangat berharap dengan hadirnya buku Bisa OpenOffice ini semakin banyak orang yang mulai menggunakan OpenOffice.

tambahkan di

#nano /etc/apt/source.list
deb http://dl2.foss-id.web.id/ubuntu/ lucid-backports main restricted universe multiverse
deb http://dl2.foss-id.web.id/ubuntu/ lucid-proposed main restricted universe multiverse
deb http://dl2.foss-id.web.id/ubuntu/ lucid-security main restricted universe multiverse
deb http://dl2.foss-id.web.id/ubuntu/ lucid-updates main restricted universe multiverse
deb http://dl2.foss-id.web.id/ubuntu/ lucid main restricted universe multiverse

Repository Speedy
deb http://opensource.telkomspeedy.com:5432/ubuntu lucid main restricted universe multiverse
deb http://opensource.telkomspeedy.com:5432/ubuntu lucid-updates main restricted universe multiverse
deb http://opensource.telkomspeedy.com:5432/ubuntu lucid-security main restricted universe multiverse

source speedy opensource

inurl:index.php?id=
inurl:trainers.php?id=
inurl:buy.php?category=
inurl:article.php?ID=
inurl:play_old.php?id=
inurl:declaration_more.php?decl_id=
inurl:pageid=
inurl:games.php?id=
inurl:page.php?file=
inurl:newsDetail.php?id=
inurl:gallery.php?id=
inurl:article.php?id=
inurl:show.php?id=
inurl:staff_id=
Read the rest of this entry »

Untuk mengamankan file agar tidak di lihat oleh sembarangan orang lain, anda dapat melakukan enkripsi filesystem partisi bersangkutan. Dari beberapa metode enkripsi yang dapat di gunakan, anda dapat menggunakan DM-Crypt ( device-mapper crypto target ).
Sekarang lansung aja kita Pelajari :

1.dalam contoh ini, kita akan menggunakan enkripsi 256-bit AES ( Advanced Encryption Standard ). Pasti jika kernel anda sudah memiliki dukungan untuk me-load module AES.
$ cat /proc/crypto
Name : md5
…..
Dari output diatas terlihat kalau module AES belum diaktifkan. Untuk mengaktifkan module AES, jalankan perintah berikut :
$ sudo modprobe aes
Name : aes
…..
Dari output diatas, dapat terlihat kalau module AES sudah berhasil di-load.

2.Berikutnya instalasikan kedua tools yang akan kita gunakan untuk melakukan enkripsi, yakni dmsetup dan cryptsetup
$ sudo apt-get install dmsetup cryptsetup

3.setelah terinstalasi dengan baik, selanjutnya anda dapat meload module dm-crypt
$ sudo modprobe dm-crypt

Read the rest of this entry »

Tags: ,